Tainacan Beta 0.18.8 - Correções de erros e compatibilidade com o WP 5.9

:tainacan:Olá comunidade! :wave:t3:

Um ótimo 2022 para todos :tada: :clinking_glasses:

De retorno às nossas atividades, estamos trazendo hoje uma pequena versão com correções de erros, voltada principalmente para resolver algumas pontas soltas e manter a compatibilidade do plugin com o WordPress 5.9, lançado esta semana. Este movimento nos permite mover para o desenvolvimento de recursos maiores planejados para este ano com a versão 0.19. Por se tratarem de questões menos impactantes, não temos post de lançamento, mas aqui vai um resumo do que está incluso na 0.18.8:

  • Compatibilidade dos blocos Gutenberg com o editor no WordPress 5.9, em particular o uso do componente de paleta de cores ao invés do seletor de cores antigo.
  • Correção do erro que estava carregando um metadado inválido na ordenação da lista de itens (apontado por diversos usuários aqui na lista);
  • Correção de erro que estava trazendo a miniatura desabilitada em alguns modos de visualização;
  • Correção de erro onde os blocos de carrossel com “loop” ativado não carregavam imagens;
  • Correção de erro onde o botão de “Ver todos os itens relacionados a este” estava levando para a coleção errada no painel administrativo;
  • Correção do alinhamento de players de áudio e vídeo no modal de mídia na página do item;
  • Correção do estilo do metadado composto no novo mapeador do importador;
  • Pequenas melhorias para a página de edição de item no mobile;
  • … e vários outros ajustes!

Muito obrigado a todos que relataram estes erros e testaram nossas versões prévias com correções. Ficamos confiantes de que o Tainacan sai cada vez mais maduro neste ciclo de lançamentos!
:fist_right:t3: :boom: :fist_left:t3:

Ah, e pra quem usa o Taiancan Interface, ele também recebeu uma pequena atualização com ajustes de CSS para a versão 5.9 do WordPress. Como sempre, podem atualizar direto dos seus painéis de plugins e temas :wink:

7 Likes