METADADOS - Item não salva informações de determinado metadado

Olá Pessoal. Estou com um problema onde, especificamente em um item de uma coleção, determinado metadado (composto) não está sendo salvo. Outros itens similares da mesma coleção, o salvamento das informações nesse mesmo metadado funciona sem problemas.

Olá @tigurio, tudo bem?

Cara, já vimos relatos deste tipo de erro mas sempre é difícil reproduzirmos. Você consegue ver se há algum erro sendo emitido no console? Consegue gravar o que está acontecendo? Faz diferença se você Ir mais devagar ao trocar o mouse de um campo do composto para outro?

Pior é que no console do browser não apresenta erro algum no console do browser.
Sobre essa questão da “velocidade em trocar de campos”, o problema ocorre mesmo se eu preencher apenas 1 dos campos.
Segue imagem animada mostrando o problema.
Peek 10-06-2022 15-09

Muito estranho, inclusive ele dizer que está salvando ali embaixo …

Semana que vem volto a tentar reproduzir isso. Mas olhando assim bem por alto a sua coleção eu já tenho um forte pressentimento de que este uso que você está fazendo do metadado composto vai poder ser melhor atendido pela sessão de metadado (que vamos lançar com a versão 0.19). Causam muita confusão estes dois conceitos e infelizmente estamos devendo entregar logo as sessões pra um divisão deste tipo…

1 Like

@tigurio isto virou uma issue aberta aqui:

E foi aberta uma pull request:

Que infelizmente nós ainda não tivemos tempo de revisar, mas assim que conseguirmos vamos puxar pros testes.

1 Like