Os itens da minha coleção não são exibidos na página de exibição da coleção do meu site

Olá pessoal!

Criei uma coleção com alguns itens, e ao acessar o link para visualizar a coleção no site, os itens não são exibidos, como aparece na imagem anexa.

O link é: Actas de Congresos o Reuniones – My Blog

Além disso, nesta página estão bloqueadas as opções: “Metadados encontrados”, “classificar”, “exibir”, “visualizar como”.

O mesmo acontece com o resto das coleções que criei, os itens não aparecem no site, como por exemplo: Libros – My Blog

Como vocês podem ver, no painel de administração (imagem em anexo), esta coleção possui 3 itens públicos, mas eles só são visualizados no painel de controle.

Estou usando a ultima versao do Tainacan: 0.20.4

Grata pela ajuda para poder expor o acervo de nossa biblioteca universitária!!

Ing. Manuela Capó


Olá @manuela.capo, tudo bem?

Este é um erro bastante incomum… eu dei uma olhada no console do navegador quando acessei a sua página e o que parece ocorrer é que alguns dos componentes JavaScript que renderizam a lista de itens não estão carregados corretamente.

A única sugestão que eu teria por hora é de remover por completo e reinstalar o plugin do Tainacan (não se preocupe com os seus dados, eles serão mantidos). Após a reinstalação, confira se o cache do seu site está limpo (se você tiver algum plugin de cache limpe ele) e recarregue a página do seu navegador usando o atalho de limpar memória cache (geralmente é CTRL + SHIFT + R) e nos diga se isso resolve, OK?

2 Likes

Olá Matheus!
Muito prazer
Muito obrigada pela sua resposta rápida.

Fiz tudo que você me disse e o problema ainda persiste.

Na verdade, quando tento acessar a página de uma categoria, abre uma imagem preta, assim como aparece no arquivo anexo, tive que recarregar a página diversas vezes até abrir, mas ainda sem mostrar os conteúdos publicados na categoria …

Mas você pode ver o conteúdo com seus metadados em sua página individual, como: El ABC de la Tabla periódica – My Blog

Porém, notei que a miniatura não aparece neste conteúdo, e em alguns outros acontece a mesma coisa, não mostra, apesar de estar configurado para mostrá-la.

O que mais você acha que devo fazer para resolver esta situação?

Muito obrigado antecipadamente pela ajuda!

Saudações!

Manuela Capo

Eu dei mais uma olhada nos logs e parece que o erro está sendo originado de algum conflito com um plugin chamado “jet-menu”… Pode experimentar desabilitar ele pra vermos se é isso mesmo?

2 Likes

Olá Matheus! Boa tarde!
Na verdade, o plugin JetMenu estava causando um conflito com o plugin Tainacan! Desativei, limpei o cache do site e tentei navegar novamente nas coleções e agora consigo ver os documentos, como na imagem em anexo!!

Você pode ver aqui uma das coleções de testes: Actas de Congresos o Reuniones – My Blog

Aliás, tive que criar outro usuário neste wiki: manuela-capo para poder enviar esta mensagem, pois meu usuário inicial com o qual criei este tópico: manuela.capo foi bloqueado, não sei por que motivo :frowning_face: talvez eu acidentalmente tenha feito algo inapropriado, me desculpe.

Mateus, muito obrigada por toda sua colaboração!!!

Aproveito para perguntar: por favor, você pode me ensinar como conseguiu ver os logs do meu site onde conseguiu encontrar o erro?
E qual plugin você recomenda para gerenciar e limpar o cache do meu site?

Grata novamente,

Saudações desde Venezuela.
Manuela Capo

Oi @manuela-capo!

Que bom que descobrimos a causa! Depois quero separar um tempo para dar uma investigada em qual pode ser o problema que este plugin causa, se tem algo que poderíamos fazer do nosso lado…

Sobre isso, o Discourse tem algumas regras configuradas para evitar spammers… como você acabou de entrar na comunidade e mandou um mesmo link repetidas vezes acho que ele interpretou como se fosse um desses casos. Não se preocupe, você não fez nada de errado.

Sobre isso você pode dar uma lida nisto aqui.

Como um dos erros era originado de um arquivo Javascript que estava na pasta do plugin, eu inferi que poderia ser problema dele.

Cache existe em vários níveis… a nível de Servidor, a nível do seu serviço de hospedagem e
a nível do navegador. No caso do navegador, não tem muito o que fazer, é usar o atalho do seu navegador pra limpar mesmo. No caso do servidor, tem plugins como o W3 Total Cache, mas ao menos que você esteja realmente buscando uma otimização no carregamento das páginas, não acho necessário, pode inclusive acabar gerando cache em situações que você não esperava.

Que massa! Nossa comunidade no México está crescendo bastante nos últimos dias, até pensei que você era de lá, mas é muito bom vermos outros países da América Latina abraçando o uso do software. Não deixe de compartilhar conosco os resultados dos seus experimentos quando tiver mais avanços.

Qualquer dúvida estamos à disposição! :tainacan: