Anexos não carregam

Bom dia a todos, espero que estejam bem.

Estou utilizando o tema Blocksy atualizado na ultima versão, pluguins Tainakan e Wp também. Quando clico em um anexo na página do item, aparece a tela dos anexos, mas os arquivos não carregam, a tela fica “pensando” e nada é mostrado.

O que pode estar ocorrendo?
Desde já agradeço
abraços

Uhmm, pode ver que mensagem tá rolando na requisição?

Oi @mateus.m.luna, blz?

Segue o print com o Console e a Network.

Uhmm não dá pra ver nada de novo aí ainda… talvez precisamos ter essa aba do console aberta antes de vc clicar nele…

Você teria como liberar este link para eu ver? Facilitaria bastante e depuração.

Sim, claro. Deixei aberto agora.

Obrigado pela atenção.

1 Like

Valeu @thiagomonteiro.geo. Já tenho alguns palpites aqui, mas semana que vem vamos te dar um retorno, ok? Se puder manter aberto :slight_smile:

Blz! @mateus.m.luna. Obrigado!

Olá @thiagomonteiro.geo!

O erro está sendo causado pelo seguinte… inspecionando lá no html da página dá pra ver:

Tá vendo aquele data-src="... ali? Deveria ser só src=".... Entretanto, não há no plugin nenhuma parte que está gerando este data-. Então temos dois palpites…

  1. Tem algum plugin ativo na instalação que talvez possa estar fazendo substituição disso… talvez algo de otimização de imagens?
  2. Por alguma razão você estaria com uma versão antiga da biblioteca que renderiza o PDF… isso é estranho pq ela fica dentro do próprio Tainacan então mesmo se fosse cache já deveria ter sido atualizado… mas é uma hipótese.

Pode testar essas questões?

Bom dia, @mateus.m.luna. Muito obrigado pelo retorno e atenção. Problema resolvido no seu primeiro palpite. Desativei o EWWW Image Optimizer e rolou a apresentação dos anexos. Você sugere outro plugin de otimização ou é mais no teste mesmo?
Abraços

Olha, não vou saber de cabeça um agora… mas talvez valha abrir uma issue ou tópico no fórum deles, mencionando o problema. Ou eles não deveria fazer isso com <iframe>s (tanto a tag <img> quanto a tag <iframe> possuem atributos src), ou deveriam ver porque este carregamento dinâmico deles do PDF que está no iframe não funcionou…