Error 403

Hi

Tainacan seems very good and also well suited for a collection of PDF documents that users can download. Unfortunately I receive a lot of Error 403 and hope you can help. I have read the wiki, in the forum etc. and have translated a lot from Portuguese to English without finding the answer :wink:

I have installed Tainacan on a new Wordpress installation with Tainacan Theme and Tainacan as the only plugin and I have tried on two different domains. I have full SSH/SFTP access and have checked permissions and also deleted .htaccess. CDN and cache is deactivated. I have tried with the “User Role Editor” plugin and also added a new User with “Tainacan Administrator” permissions but the problem is the same.

I can do some without errors as I have made a Collection (SaSp) with 3 Items (music nodes) on my test site. I can add Header Image and delete it again without problems. I can also add New Taxonomy, but I can’t delete them again (Error 403)! When I try to add Metadata and Filters I get Error 403, so I can’t add them. Under Importers I also get Error 403 when I try to create the 2 test collections. Exporters work for CSV file.

Is Metadata, Filters and New Taxonony saved in a special way that could be a problem with the server setup?

I pay for hosting at www.one.com, and it’s a big company hosting more than 1,5 mio. websites. I haven’t contacted them yet, as I don’t know what I need to be changed in order for it to work.

My test site can be seen here:

Hi @pdamgaard, welcome to our forum!

We’re glad that Tainacan seems to suits your needs and sorry to see that you are facing this issue.

The error that you are describing is hard to debug. As you may have seen, we have had users who faced similar situations here in the forum and often there was some limitation or blocking made by their hosting providers.

Now, the fact that some operations work and others don’t really makes things trickier but can also be a clue. Talking to one of our developers here, he brought to the table the idea that maybe GET and POST requests are authorized, but PUT, PATCH and DELETE are not. This is a technical detail on how the requests are made internally. To see if that could be the case, we would have to investigate better.

In order to see if that is the case, we would need a few screenshots from the network panel in your browser, at the moment that any of this requests go wrong. We have some instructions about how to obtain this information here:

If that sounds too complicated, could we have access via a login to your website, so we can try things by ourselves?

Hi @mateus.m.luna, and thank you for your prompt reply the other day.

I contacted my host, One.com, right away and they said there are no restrictions with PUT, PATCH and DELETE. They offered to look further into the issue on my test-site with only Tainacan installed and I gave them full access with an admin user in Wordpress, and this is what they wrtite now:

… it appears that the issue is more related to Tainacan plugin capabilities and permissions. The issue exists despite all other plugins are disabled and all .htaccess are renamed upon all troubleshooting methods we have done. We would need to advice you to check with Tainacan support".
<<<

You propose I give you access, and I’m happy to do that. How/where can I send you the access?

An update and kind of a solution. @mateus.m.luna offered to look at it, and for trial and error I installed on another domain on the same shared hosting solution.

I have 10 domains in the same shared hosting, and while there are several 403 Errors on four subdomains at the same domain, I have successfully installed Tainacan on two other domains in the same shared hosting! My subdomains are all new WordPress installations with Tainacan only, so it’ really doesn’t make much sense.

But there is an unidentified problem at one domain that creates 403 Errors, but I’m moving my testing to other domains as it’s not important for me that it works on my first test-domain. But thanks for the help trying to solve this - highly appreciated.